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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It includes instructions to assign an excitation in a Maxwell design and create and solve
an Icepak design based on the same geometry.

This chapter contains the following topic:

l "Sample Project - The Coil and Plate" below

Sample Project - The Coil and Plate
In this project, you will learn how to perform Maxwell to Icepak coupling. Maxwell calculates the
EM losses, and Icepak solves for thermal fields.

Figure 1-1: Coil and Plate

Getting Started with Icepak®: Coil and Plate

Introduction 1-1

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 1-2

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: Coil and Plate



2 - Run the Maxwell Simulation
This chapter contains the following topics:

l Open the Project
l Review the Maxwell Design
l Analyze the Maxwell Design and Report Losses

Open the Project
This chapter contains the following topics:

l Launch the Ansys Electronics Desktop

Launch the Ansys Electronics Desktop
A shortcut of the Ansys Electronics Desktop application appears on your desktop once the applic-
ation is installed.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

Getting Started with Icepak®: Coil and Plate
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3. ClickOK.

Open the Project

1. On the Desktop ribbon tab, click Open Examples. Then:
a. In theOpen dialog box that appears, click the parent folder icon ( ) once to move

up one level above the Examples folder.
b. Double-click the Help folder and then the Icepak folder.
c. Select the file Coil_Plate_Maxwell.aedt and clickOpen.

2. The model is displayed in the 3D Modeler window.

Run the Maxwell Simulation 2-2
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Figure 2-1: Coil and copper plate model in the 3D Modeler window

3. From the Filemenu, select Save As, and save the project in the desired working dir-
ectory.

Review the Maxwell Design
1. In the history tree, expandModel > Solids > copper_temp, FR4_epoxy, and vacuum

and review the component geometry.

Figure 2-2: History tree

Note: The coil and plate material assignment is copper_temp, and the insulation is set to
FR4_epoxy. Right-click on a material and select Properties to view a material's various
properties.

2. From theMaxwell 3Dmenu, select Solution Type. Note that the solution type is set to
Eddy Current and clickOK.

Run the Maxwell Simulation 2-3
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Figure 2-3: Solution Type dialog box

3. In the Project Manager, expand Excitations and select Current1.
4. In the Properties window, note the Evaluated Value.

Figure 2-4: Properties window - Current1

Run the Maxwell Simulation 2-4
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Analyze the Design and Report EM Losses
1. In the Project Manager, expand Analysis.
2. Right-click on the solution setup (Setup1) and select Analyze to run the Maxwell sim-

ulation.
3. Right-click Setup1 and select Convergence.
4. Change the View to Plot and, from the Y: drop-down list, select Energy Error [%].

Note:When the simulation is complete, a message is displayed in theMessage Manager
indicating normal completion.

5. After the simulation is complete and you're finished reviewing the convergence plot, click
Close.

6. From theMaxwell 3Dmenu, select Fields > Calculator to open the Fields Calculator.
7. Under Input, clickQuantity and select EMLoss.
8. ClickGeometry, select Volume, select AllObjects, and click OK.

9. Under Scalar, click Integrate ( ).
10. UnderOutput, click Eval. The EM loss is calculated.

Note: The EM loss is displayed in Watts.

Run the Maxwell Simulation 2-5
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Figure 2-5: Fields Calculator

11. Confirm the EM loss, and click Done to close the Fields Calculator.

Run the Maxwell Simulation 2-6
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12. From the Filemenu, select Save.
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3 - Prepare and Run the Icepak Sim-
ulation

This chapter contains the following topics:
l Set Up the Icepak Design
l Assign Thermal Boundary Conditions
l Set Solution Type
l Define Design Settings
l Add a Solution Setup
l Generate a Global Mesh
l Run the Icepak Simulation

Set Up the Icepak Design
1. In the history tree, right-clickModel and select Select All.

Figure 3-1: History Tree

2. From the Editmenu, select Copy to copy all of the geometry and material information.
Alternatively, you can press Ctrl + C to copy the geometry.

3. On the Desktop ribbon, click Icepak.

Getting Started with Icepak®: Coil and Plate
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Figure 3-2: Project Manager

4. Right-click in the 3D Modeler window and select Edit > Paste. The geometry from the
Maxwell design is inserted into the Icepak design. Alternatively, you can press Ctrl + V to
paste the geometry.

5. On the Draw ribbon, click Fit All. Alternatively, you can press Ctrl + D to fit the geometry.

Figure 3-3: Draw ribbon - Fit All

Prepare and Run the Icepak Simulation 3-2
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Figure 3-4: Coil and Plate Geometry in Icepak Design

Note: The Region geometry (computational domain) is automatically created.

6. In the history tree, expandModel > Solids >Air > Region and select CreateRegion.
7. In the Properties dialog box, edit the Value for -Z Padding Data and then +Z Padding

Data as shown in the following figure to expand the computational domain in the direction
of gravity for natural convection analysis.

Note:

Ensure that you enter padding values for -Z Padding Dat before +Z Padding
Data.

Prepare and Run the Icepak Simulation 3-3
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Figure 3-5: Properties window - CreateRegion

8. ClickOK to apply the changes and close the dialog box.
9. In the history tree, right-click copper_temp and select Properties to examine the thermal

material properties.
10. After reviewing the properties, clickOK.

Prepare and Run the Icepak Simulation 3-4
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Figure 3-6: Select Definition dialog box

Assign Thermal Boundary Conditions
Assign an Opening

1. Press F to enter face selection mode.
2. In the 3D Modeler window select all six sides of the Region geometry.

Note: Use the middle mouse button or the control key and the Rotate tool on the Draw rib-
bon to select all six faces.

Prepare and Run the Icepak Simulation 3-5
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Figure 3-7: Sides of Region geometry

3. Right-click in the 3D Modeler window and select Assign Thermal > Free >Opening.
4. In theOpening Thermal Model dialog box, retain the default settings and click OK.

Assign the EM Volume Loss
1. In the history tree, select coil, plate, and nomex using the control key.

Prepare and Run the Icepak Simulation 3-6
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Figure 3-8: History tree - EM loss selection

2. Right-click in the 3D Modeler window and select Assign Thermal > EM Loss.
3. In the Setup Link dialog box, select the Use This Project check box.
4. On the Variable Mapping tab, click Map Variable by Name to compare the source

design variables to the Icepak design variables. Any variables with the same name are
mapped so that the source design conforms to the Icepak design.

5. ClickOK.
6. In the EM Loss dialog box, enter VolumeLoss as the Name.
7. Ensure the coil, plate, and nomex are listed under Volume. If they are not, drag them

under Volume to designate a volume loss.
8. ClickOK.

Figure 3-9: Project Manager - Thermal Boundary Conditions

9. From the Filemenu, select Save.

Create a Face Monitor
To check the temperature of a specified face during a solution, create a monitor surface and
assign a face monitor to it.

1. Press F to enter face selection mode.
2. In the 3D Modeler window, select and right-click the top surface of the coil.

Prepare and Run the Icepak Simulation 3-7
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Figure 3-10: Face Selection

3. From the right-click menu, select Assign Monitor > Face.
4. In theMonitor Setup dialog box, select Temperature and click OK. The face monitor

appears underMonitor in the Project Manager.

Figure 3-11: Project Manager - Monitor

Set Solution Type
Specify the design’s solution type as follows:

1. Click Icepak>Solution Type.

The Solution Type dialog box appears.

2. Ensure that Steady State and Temperature and Flow are selected and clickOK.

Prepare and Run the Icepak Simulation 3-8
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Figure 3-12: Solution Type

Define Icepak Design Settings
Specify the project design settings as follows:

1. Click Icepak>Design Settings.
2. On theGravity tab, ensure theGravity Vector is set toGlobal::Z and Negative as

shown in the following figure.

Figure 3-13: Icepak Design Settings dialog box

Prepare and Run the Icepak Simulation 3-9
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3. Retain the default settings on the other tabs and clickOK.

Add a Solution Setup
Create a solution setup, in which you specify general and advanced solution settings.

1. In the Project Manager, right-click on Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup Dialog General tab:

l ForMaximum Number of Iterations, enter 300.
l Under Flow Regime, retain the default selection of Laminar.
l Under Radiation Model, select Discrete Ordinates.
l Select Include Gravity.

Prepare and Run the Icepak Simulation 3-10
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Figure 3-14: Icepak Solve Setup Dialog - General tab

3. On the Solver Settings tab:
l Under Initial Conditions, enter 0.001 as the Z Velocity and retain the unitm_per_
sec. Generally, if you solve a natural convection problem, the initial condition
should be a small value in the opposite direction of gravity because the force driving
the flow is weak to proceed with the calculation.

l Click Advanced Options.
4. In the Advanced Solver Settings dialog box:

l For Pressure, enter 0.7 for Under-relaxation and select Body Force for Dis-
cretization Scheme.

Prepare and Run the Icepak Simulation 3-11
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Note:

Adjust under-relaxation factors in advance because a calculation tends to
be unstable in case of natural convection.

l ForMomentum, enter 0.3 for Under-relaxation.
l Retain the default Linear Solver Options and click OK.

Prepare and Run the Icepak Simulation 3-12
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Figure 3-15: Advanced Solver Settings

5. On the Radiation tab:

Prepare and Run the Icepak Simulation 3-13
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l Under Iteration Parameters, enter 5 for Flow Iterations per Radiation Iteration.
l Under Angular Discretization, enter 2 for Theta Divisions, Phi Divisions, Theta
Pixels, and Phi Pixels.

Note: For coarse models without angled faces, a value of 1 is acceptable, and for
fine models with angled faces, a value of 2 or 3 should be used. Note that increas-
ing the angular discretization has a large impact on overall CPU time.

Figure 3-16: Icepak Solve Setup Dialog - Radiation tab

6. ClickOK to save the settings. The solution setup is added under Analysis in the Project
Manager.

7. From the Filemenu, click Save.

Prepare and Run the Icepak Simulation 3-14

Ansys Electromagnetics Suite 2025 R1 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with Icepak®: Coil and Plate

Generate a Global Mesh
When the model geometry is finished, you can mesh the model. In this example, you'll create a
global mesh using the advanced mesh settings.

View Global Mesh Settings
1. In the Project Manager, right-click onMesh and select Edit Global Region.
2. In theMesh Region dialog box, retain the default settings on theGeneral tab.
3. On the Advanced tab select User specified and edit the following settings:

l UnderMaximum Element Size, enter 2 mm for X, Y, and Z.
l UnderMinimum Gap, enter 0.1 mm for X, Y, and Z.
l UnderMulti-level meshing, select Enable and enter 2 forMax Levels and 1 for
Buffer Layers.

Prepare and Run the Icepak Simulation 3-15
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Figure 3-17: Mesh Region dialog box - Advanced tab

4. ClickOK.

Create a Mesh Operation
Create a mesh operation to specify a division level for the selected objects. The mesh operation
setting allows to uniform the mesh size of the surface.

1. In the history tree, select coil, plate, and nomex.
2. Right-click and select Assign Mesh Operation.
3. In theMesh Operation dialog box under Level, enter 2 forMax.
4. Click OK.

Prepare and Run the Icepak Simulation 3-16
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Generate and Examine the Mesh
1. On the Simulation ribbon, clickGenerate Mesh. When the mesh operation is complete,

the mesh loads and theMesh visualization dialog box appears.
2. In theMesh visualization dialog box underMesh display on, selectGeo-

metry/Boundary selection.
3. In the history tree, select coil, plate, and nomex to display the mesh for the selected

objects.

4. On the View ribbon, click the Isometric orientation option from theOrient drop-down
list.

Figure 3-18: Global Mesh

5. In theMesh visualization dialog box, click theQuality tab and toggle between Face
alignment, Volume, and Skewness, noting theMin value andMax value for each.

Note: The following are targets value for face alignment and skewness that increase the
probability of simulation convergence and accurate results.

l Face alignment: >0.05
l Skewness: >0.02

6. Click Close to close theMesh visualization dialog box.

Run the Icepak Simulation
1. In the Project Manager under Analysis, right-click Setup1 and select Analyze.
2. Right-click on Setup1 again and select Residual to open the Solutions dialog box, where

you can view the solution residuals as they are updated with each iteration.

Prepare and Run the Icepak Simulation 3-17
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Figure 3-19: Solutions Dialog Box - Residual tab

3. Click the Thermal Monitor tab and review the monitor data.

Prepare and Run the Icepak Simulation 3-18
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Figure 3-20: Solutions Dialog Box - Thermal Monitor tab

4. Click the Profile tab and review the EM loss data.

Prepare and Run the Icepak Simulation 3-19
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Figure 3-21: Solutions Dialog Box - Profile tab

5. Click Close.

Prepare and Run the Icepak Simulation 3-20
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4 - Postprocess the Icepak Simulation
This chapter contains the following topics:

l Create Field Plots
l Create a Fields Summary

Create Field Plots
Create a Temperature Field Plot

1. In the history tree, select coil, plate, and nomex.
2. Right-click on the selection and select Plot Fields > Temperature > Temperature.
3. In the Create Field Plot dialog box, retain the default selections underQuantity and

In Volume.
4. Select the Plot on surface only check box.
5. Click Done.
6. Right-click on the Temperature legend and selectModify.
7. On the Scale tab under Number Format, select Decimal for Type and enter 6 forWidth.
8. Click Set as default and then Close.

Getting Started with Icepak®: Coil and Plate
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Figure 4-1: Temperature Field Plot

Create a Plane
In order to display velocity on a plane cut, you must first create a plane. The plane will be in the
middle of the model in the X direction.

1. On the View ribbon, click the Isometric orientation button from theOrient drop-down
list.

2. On the Draw ribbon, click the Draw Plane button .
3. In the 3D Modeler, hover the cursor over the center of the model along with X plane.
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Figure 4-2: Plane creation

4. Hold Y, move the cursor up along the Y plane and click. The new plane displayed under
Planes in the history tree.

Create a Velocity Vector Plot
1. In the history tree, expand Planes and select the plane you created.
2. In the 3D Modeler window, right-click and select Plot Fields>Velocity>Velocity

Vectors.
3. In the Create Field Plot dialog box, retain the default selection of Velocity Vectors under

Quantity and click Done. Velocity vectors are displayed on the plane.

Note: Click and drag the Velocity colorkey to also display the Temperature colorkey.
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Figure 4-3: Velocity vectors on a plane

Create a Fields Summary
Verify the energy balance using the Fields Summary report. The mapped loss is the only source
of heat for the model. For a well converged solution, the heat dissipated from the system should
be very close to the heat generated in the system.

1. On the Results ribbon, click Create Fields Summary.
2. In the Setup Calculation dialog box under Entity, selectOpening1.
3. UnderQuantity, select HeatFlowRate.
4. Under Side, select Adjacent.
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Figure 4-4: Setup Calculation

5. Click the Add drop-down button and select Add as a Single Calculation.
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Figure 4-5: Fields Summary
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